Saurik Says Updates Are Coming in the 'Relatively Near Future', Warns Against Installing His Packages on Electra

With everything that’s going on lately in the jailbreak community as of late, it’d be an understatement to say that people want to know what’s happening with Saurik and the iOS 11 update for Cydia and Mobile Substrate that he talked about on Reddit several weeks ago.

 The comment follows an issue encountered by Electra jailbreakers who updated to a new APT build recently pushed. Saurik warns not to install any of the packages he pushes if jailbroken with Electra.

Unsurprisingly, he won’t support unofficial versions of Cydia or their dependencies and recommends that Electra users don’t install any of his official updates for the sake of jailbreak stability.
FWIW, people using Electra are essentially using a fork of everything I’ve ever done that was put together by coolstar with no thought to how it would affect anything else I’m working on or will be releasing, either in the near future or in the distant future; so, if you have installed Electra, I would strongly recommend never installing any of the packages I push going forward: I have done no testing with Electra nor do I have any interest at all in spending time I don’t really have to try to figure out how to maintain compatibility with Electra.

The new version of Cydia I’m going to be pushing will probably not work without the new version of Substrate, and I’m pretty sure the new version of Substrate I’m going to be pushing will not work on Electra (it definitely doesn’t work on LiberiOS, which is a “vaguely supported upgrade path”; it is possible it will sort of “half” work on Electra, and there’s one design option which might allow it to sort of work, but I’ve been leaning towards two other ways of doing it that I already have working, one of which simply could not ever function correctly on Electra and the other one which simply is assuming a bootstrap process that is based on the Cydia jailbreak instead of on Electra).
What this boils down to is: if you’ve used Electra to jailbreak your iOS 11.0-11.1.2 device, then you shouldn’t run to Saurik for help with Cydia or dependency-related problems. Instead, he advises directing any Electra-related questions to CoolStar.

Saurik also notes that the new version of Cydia probably won't work without the new version of Substrate and the new version of Substrate likely will not work on Electra. 

At this point in time, jailbreakers can either continue waiting for Saurik’s official releases or jump the gun with CoolStar’s Electra jailbreak tool. The decision is ultimately up to you to make, but you should look at the big picture and consider all options before deciding.



blog comments powered by Disqus
Octofinder Blog Catalog